Triton Basic Troubleshooting

“LINK” Icon is Not Displaying

  • Make sure transmitter and receiver are powered ON
  • Make sure both units are on the same channel
  • Make sure the transmitter and receiver are within range. Ideal range for linking is within 250 feet (75 meters)
  • If problem persists, powercycle both transmitter and receiver


“VIDEO” Icon is Not Displaying on LCD Screen

  • Make sure transmitter and receiver(s) are powered ON
  • Make sure all units are on the same channel (1-8)
  • Make sure the transmitter and receiver are within range. Maximum range is 450 feet (140 meters)
  • Check the HDMI cable from the video source into the transmitter. Unplug and plug it back in again. Try a different HDMI cable if the problem persists.
  • If you have changed framerates on your video source, you may need to powercycle the transmitter and receiver(s) for the video signal to be sent.
  • If problem persists, check that your video source supports HDCP authentication.


“VIDEO” Icon is ON, but Video Signal Will Not Display on Monitor

  • Make sure your monitor is powered ON and not in standby mode
  • Make sure your HDMI cable is plugged into the selected video input
  • Make sure the transmitter and receiver are within range. Maximum range is 450 feet (140 meters)
  • Check the HDMI cable from receiver to the monitor. Unplug and plug it back in again.
  • Try a different HDMI cable if the problem persists.
  • Check to see that your monitor supports the video framerate being sent from source

Abnormal Color/Tint on Video Signal

  • Unplug the HDMI cables on the transmitter & receiver and plug them back in again.
  • Powercycle the transmitter and receiver
  • Try different HDMI cables


Digital Noise on the Image

  • Make sure the transmitter and receiver are within range (maximum 450 ft/140m).
  • Bring them closer together to see if the problem persists
  • If there are several walls or obstacles in between the transmitter and receiver, try to remove them or raise the units to send the signal over them


Video Signal is Fine but There is No Audio

  • Make sure the video source is not muted
  • Make sure the volume on your monitor is turned up
  • Check to make sure your monitor supports the audio format sent by the video source.
  • Change audio format if necessary. If audio format has been changed, powercycle both transmitter and receiver
  • Try different HDMI cables on your receiver and transmitter in case it is a problem with the cable(s)
  • If the Microphone icon is displayed on the transmitter LCD, make sure an audio signal is being sent through the 3.5mm audio input on the transmitter
  • If the Microphone icon is NOT displayed on the transmitter LCD, make sure an audio signal is being sent through the HDMI cable
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk